Mystery WordPress/Markdown Problem: Troubleshooting [en]

[fr] Description d'un vilain problème WordPress avec PHP Markdown Extra. Certains billets refusaient de s'afficher et faisaient tout simplement planter la suite du chargement de la page (donc, pages archives incomplètes, billets disparus). J'ai résolu (plus ou moins) le problème en remplçant PHP Markdown Extra par Markdown tout court, mais je n'ai toujours pas compris le fond du problème. Ce billet donne quelques détails sur les symptômes et mes déductions.

If you’re a WordPress person and you feel like a bit of juicy troubleshooting, this one is for you. I’ve narrowed down part of the problem, but have failed to identify clearly the cause of the problem. I’ve found a workaround by replacing a plugin by another similar one, however. I’ve [made screenshots](http://flickr.com/photos/bunny/tags/vmdisplayproblem) so that even once this problem is fixed (hopefully very quickly) you can make sense of this post.

**Symptoms:**

Some posts on the [VibrationsMusic](http://vibrationsmusic.com) website fail to display their content, or display incompletely. When this happens, the page stops loading altogether, resulting in a truncated page. (So we have vanishing posts and [incomplete aborted archive pages](http://flickr.com/photos/bunny/478123395/) where they should appear.) No error messages in source, HTML code just stops.

**Narrowing it down:**

Removing post content makes the post display OK, so I figured it had something to do with the content. Removing the [PHP Markdown Extra plugin](http://www.michelf.com/projects/php-markdown/extra/) removed the problem, to. So it has something to do with a combination of certain things in the content and the PHP Markdown Extra plugin. (Removing other plugins didn’t change a thing, so I deduce from that it isn’t a plugin interaction issue.)

Using the “cut-half-out” technique I tried to narrow down the problem to a certain type of post content. At first, it seemed to be caused by either (a) HTML links in Markdown lists or (b) embedded YouTube players (<object>). However, some posts with either (a) or (b) were displaying correctly. In one faulty post, replacing the embedded YouTube video with another removed the problem.

However, it seems more subtle than that. In some cases, removing the *other* half of the post also removes the problem. => post length? Not really either. In a quite weird case, one post [stops displaying right at the end of the content](http://flickr.com/photos/bunny/478123369/) (Technorati tags and closing divs don’t appear) and if changes are made to the **next** post (like removing its content) [then the **first** post displays correctly](http://flickr.com/photos/bunny/478123489/) (and the second one too).

This seems (to me) to point to some problem in the query-array-manipulation area (but I don’t know how things work well enough in that department to make a more precise hypothesis).

**Workaround:**

I replaced the PHP Markdown Extra plugin with the [“normal” Markdown plugin](http://www.michelf.com/projects/php-markdown/), and everything displays fine.

Similar Posts:

1 thought on “Mystery WordPress/Markdown Problem: Troubleshooting [en]

  1. Is it really working fine ?
    – even with lists ?
    – even with a dummy using it ?
    – we’ll see

    You can, of course, delete this comment !

Leave a Reply

Your email address will not be published. Required fields are marked *